pkg-config::is-between-version

[This is preliminary documentation and subject to change.]

Determines whether the given package is between two versions.

Usage

bool pkg-config::is-between-version(package, minVersion, maxVersion)

Parameters

Name Type Description
package string The package to check.
minVersion string The version the package should at least have.
maxVersion string The version the package should maximum have.

Return Value

true if the given package is between minVersion and maxVersion; otherwise, false.

Exceptions

The function will fail in any of the following circumstances:

Requirements

Assembly: NAnt.Core (0.92.4526.0)