System Requirements

[This is preliminary documentation and subject to change.]

To use NAnt you need one of the following CLR's:

Note: Additional requirements may apply to individual tasks.

Library Dependencies

NAnt uses a number of open source third party libaries.  Recent versions are included included with the NAnt distribution and no extra work is required to install them.  More information on these libraries are available at:

> NUnit - Required for unit testing

> NDoc - Required for documentation generation

> SharpZipLib - Required for the zip and unzip tasks